[root@machine1 ~]# uname -a
Linux machine1 2.6.32-642.3.1.el6.x86_64 #1 SMP Sun Jun 26 18:16:44 EDT 2016 x86_64 x86_64 x86_64 GNU/Linux
[root@machine1 ~]#

[root@machine1 ~]#  yum repolist
Loaded plugins: aliases, changelog, package_upload, presto, product-id, search-disabled-repos, security, subscription-manager, verify, versionlock
rhel-6-server-rpms                                                                                                                                                                                                    | 2.1 kB     00:00
rhel-6-server-satellite-tools-6.2-rpms                                                                                                                                                                                | 2.1 kB     00:00
repo id                                                                                                  repo name                                                                                                                 status
rhel-6-server-rpms                                                                                       Red Hat Enterprise Linux 6 Server (RPMs)                                                                                  17,566+548
rhel-6-server-satellite-tools-6.2-rpms                                                                   Red Hat Satellite Tools 6.2 (for RHEL 6 Server) (RPMs)                                                                            68
repolist: 17,634
[root@machine1 ~]#

[root@machine1 ]$ yum info git

Loaded plugins: aliases, changelog, package_upload, presto, product-id, search-disabled-repos, security, subscription-manager, verify, versionlock
Repo rhel-6-server-satellite-tools-6.2-rpms forced skip_if_unavailable=True due to: /etc/pki/entitlement/6082406853867915535-key.pem
Repo rhel-6-server-rpms forced skip_if_unavailable=True due to: /etc/pki/entitlement/6082406853867915535-key.pem
https://uv1398.emea.eu.int/pulp/repos/EMA/Test/rhel6_x86_64/content/dist/rhel/server/6/6Server/x86_64/os/repodata/repomd.xml: [Errno 14] problem with the local client certificate
Trying other mirror.
https://uv1398.emea.eu.int/pulp/repos/EMA/Test/rhel6_x86_64/content/dist/rhel/server/6/6Server/x86_64/sat-tools/6.2/os/repodata/repomd.xml: [Errno 14] problem with the local client certificate
Trying other mirror.
Available Packages
Name        : git
Arch        : x86_64
Version     : 1.7.1
Release     : 4.el6_7.1
Size        : 4.6 M
Repo        : rhel-6-server-rpms
Summary     : Fast Version Control System
URL         : http://git-scm.com/
License     : GPLv2
Description : Git is a fast, scalable, distributed revision control system with an
            : unusually rich command set that provides both high-level operations
            : and full access to internals.
            :
            : The git rpm installs the core tools with minimal dependencies.  To
            : install all git packages, including tools for integrating with other
            : SCMs, install the git-all meta-package.

[root@machine1 ]$ rpm -q git
package git is not installed

[root@machine1 ~]# yum install git
Loaded plugins: aliases, changelog, package_upload, presto, product-id, search-disabled-repos, security, subscription-manager, verify, versionlock
Setting up Install Process
rhel-6-server-rpms                                                                                                                                                                                                    | 2.1 kB     00:00
rhel-6-server-satellite-tools-6.2-rpms                                                                                                                                                                                | 2.1 kB     00:00
Resolving Dependencies
--> Running transaction check
---> Package git.x86_64 0:1.7.1-4.el6_7.1 will be installed
--> Processing Dependency: perl-Git = 1.7.1-4.el6_7.1 for package: git-1.7.1-4.el6_7.1.x86_64
--> Processing Dependency: perl(Git) for package: git-1.7.1-4.el6_7.1.x86_64
--> Processing Dependency: perl(Error) for package: git-1.7.1-4.el6_7.1.x86_64
--> Running transaction check
---> Package perl-Error.noarch 1:0.17015-4.el6 will be installed
---> Package perl-Git.noarch 0:1.7.1-4.el6_7.1 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================================================================================================================================================================================
 Package                                                Arch                                               Version                                                      Repository                                                      Size
=============================================================================================================================================================================================================================================
Installing:
 git                                                    x86_64                                             1.7.1-4.el6_7.1                                              rhel-6-server-rpms                                             4.6 M
Installing for dependencies:
 perl-Error                                             noarch                                             1:0.17015-4.el6                                              rhel-6-server-rpms                                              29 k
 perl-Git                                               noarch                                             1.7.1-4.el6_7.1                                              rhel-6-server-rpms                                              28 k

Transaction Summary
=============================================================================================================================================================================================================================================
Install       3 Package(s)

Total download size: 4.7 M
Installed size: 15 M
Is this ok [y/N]: y
Downloading Packages:
Setting up and reading Presto delta metadata
Processing delta metadata
Package(s) data still to download: 4.7 M
(1/3): git-1.7.1-4.el6_7.1.x86_64.rpm                                                                                                                                                                                 | 4.6 MB     00:00
(2/3): perl-Error-0.17015-4.el6.noarch.rpm                                                                                                                                                                            |  29 kB     00:00
(3/3): perl-Git-1.7.1-4.el6_7.1.noarch.rpm                                                                                                                                                                            |  28 kB     00:00
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                                                                        6.3 MB/s | 4.7 MB     00:00
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : 1:perl-Error-0.17015-4.el6.noarch                                                                                                                                                                                         1/3
  Installing : git-1.7.1-4.el6_7.1.x86_64                                                                                                                                                                                                2/3
  Installing : perl-Git-1.7.1-4.el6_7.1.noarch                                                                                                                                                                                           3/3
Uploading Package Profile
  Verifying  : perl-Git-1.7.1-4.el6_7.1.noarch                                                                                                                                                                                           1/3
  Verifying  : 1:perl-Error-0.17015-4.el6.noarch                                                                                                                                                                                         2/3
  Verifying  : git-1.7.1-4.el6_7.1.x86_64                                                                                                                                                                                                3/3

Installed:
  git.x86_64 0:1.7.1-4.el6_7.1

Dependency Installed:
  perl-Error.noarch 1:0.17015-4.el6                                                                                     perl-Git.noarch 0:1.7.1-4.el6_7.1

Complete!
[root@machine1 ~]#

[root@machine1  ]$ git --version
git version 1.7.1
[root@machine1 ]$